Transcript of Ubuntu 7.10 Gutsy Ruby On Rails vMachine Install

Here’s an example transcript of a RoR install on Ubuntu Gutsy, from our real-time-install script:

Get:1 http://security.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://security.ubuntu.com gutsy-security/main Translation-en_US
Get:2 http://archive.ubuntu.com gutsy Release.gpg [191B]
Ign http://archive.ubuntu.com gutsy/main Translation-en_US
Ign http://security.ubuntu.com gutsy-security/restricted Translation-en_US
Ign http://security.ubuntu.com gutsy-security/universe Translation-en_US
Ign http://security.ubuntu.com gutsy-security/multiverse Translation-en_US
Get:3 http://security.ubuntu.com gutsy-security Release [51.2kB]
Ign http://archive.ubuntu.com gutsy/restricted Translation-en_US
Ign http://archive.ubuntu.com gutsy/universe Translation-en_US
Ign http://archive.ubuntu.com gutsy/multiverse Translation-en_US
Get:4 http://archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://archive.ubuntu.com gutsy-updates/main Translation-en_US
Ign http://archive.ubuntu.com gutsy-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com gutsy-updates/universe Translation-en_US
Ign http://archive.ubuntu.com gutsy-updates/multiverse Translation-en_US
Hit http://archive.ubuntu.com gutsy Release
Get:5 http://archive.ubuntu.com gutsy-updates Release [58.5kB]
Get:6 http://security.ubuntu.com gutsy-security/main Packages [73.5kB]
Hit http://archive.ubuntu.com gutsy/main Packages
Hit http://archive.ubuntu.com gutsy/restricted Packages
Hit http://archive.ubuntu.com gutsy/universe Packages
Hit http://archive.ubuntu.com gutsy/multiverse Packages
Hit http://archive.ubuntu.com gutsy/main Sources
Hit http://archive.ubuntu.com gutsy/restricted Sources
Hit http://archive.ubuntu.com gutsy/universe Sources
Hit http://archive.ubuntu.com gutsy/multiverse Sources
Get:7 http://archive.ubuntu.com gutsy-updates/main Packages [245kB]
Get:8 http://security.ubuntu.com gutsy-security/restricted Packages [14B]
Get:9 http://security.ubuntu.com gutsy-security/universe Packages [45.6kB]
Get:10 http://security.ubuntu.com gutsy-security/multiverse Packages [2903B]
Get:11 http://security.ubuntu.com gutsy-security/main Sources [13.3kB]
Get:12 http://security.ubuntu.com gutsy-security/restricted Sources [14B]
Get:13 http://security.ubuntu.com gutsy-security/universe Sources [6227B]
Get:14 http://security.ubuntu.com gutsy-security/multiverse Sources [833B]
Get:15 http://archive.ubuntu.com gutsy-updates/restricted Packages [4263B]
Get:16 http://archive.ubuntu.com gutsy-updates/universe Packages [72.4kB]
Get:17 http://archive.ubuntu.com gutsy-updates/multiverse Packages [9942B]
Get:18 http://archive.ubuntu.com gutsy-updates/main Sources [68.2kB]
Get:19 http://archive.ubuntu.com gutsy-updates/restricted Sources [937B]
Get:20 http://archive.ubuntu.com gutsy-updates/universe Sources [11.5kB]
Get:21 http://archive.ubuntu.com gutsy-updates/multiverse Sources [1883B]
Fetched 667kB in 6s (103kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
wget is already the newest version.
mc is already the newest version.
ssh is already the newest version.
rsync is already the newest version.
The following extra packages will be installed:
libcurl3
The following NEW packages will be installed:
arj curl libcurl3 lynx rar rzip unrar unzip zip
0 upgraded, 9 newly installed, 0 to remove and 26 not upgraded.
Need to get 2621kB of archives.
After unpacking 8102kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com gutsy/universe arj 3.10.22-3 [218kB]
Get:2 http://archive.ubuntu.com gutsy/main libcurl3 7.16.4-2ubuntu1 [182kB]
Get:3 http://archive.ubuntu.com gutsy/main curl 7.16.4-2ubuntu1 [175kB]
Get:4 http://archive.ubuntu.com gutsy/main lynx 2.8.6-2ubuntu1 [1166kB]
Get:5 http://archive.ubuntu.com gutsy/multiverse rar 1:3.7b1-2 [506kB]
Get:6 http://archive.ubuntu.com gutsy/universe rzip 2.1-1 [17.2kB]
Get:7 http://archive.ubuntu.com gutsy/multiverse unrar 1:3.7.3-1.1 [97.0kB]
Get:8 http://archive.ubuntu.com gutsy/main unzip 5.52-10ubuntu1 [154kB]
Get:9 http://archive.ubuntu.com gutsy/main zip 2.32-1 [106kB]
Fetched 2621kB in 9s (266kB/s)
Selecting previously deselected package arj.
(Reading database … 29642 files and directories currently installed.)
Unpacking arj (from …/arj_3.10.22-3_i386.deb) …
Selecting previously deselected package libcurl3.
Unpacking libcurl3 (from …/libcurl3_7.16.4-2ubuntu1_i386.deb) …
Selecting previously deselected package curl.
Unpacking curl (from …/curl_7.16.4-2ubuntu1_i386.deb) …
Selecting previously deselected package lynx.
Unpacking lynx (from …/lynx_2.8.6-2ubuntu1_i386.deb) …
Selecting previously deselected package rar.
Unpacking rar (from …/rar_1%3a3.7b1-2_i386.deb) …
Selecting previously deselected package rzip.
Unpacking rzip (from …/archives/rzip_2.1-1_i386.deb) …
Selecting previously deselected package unrar.
Unpacking unrar (from …/unrar_1%3a3.7.3-1.1_i386.deb) …
Selecting previously deselected package unzip.
Unpacking unzip (from …/unzip_5.52-10ubuntu1_i386.deb) …
Selecting previously deselected package zip.
Unpacking zip (from …/archives/zip_2.32-1_i386.deb) …
Setting up arj (3.10.22-3) …
Setting up libcurl3 (7.16.4-2ubuntu1) …

Setting up curl (7.16.4-2ubuntu1) …
Setting up lynx (2.8.6-2ubuntu1) …

Setting up rar (1:3.7b1-2) …
Setting up rzip (2.1-1) …
Setting up unrar (1:3.7.3-1.1) …
Setting up unzip (5.52-10ubuntu1) …
Setting up zip (2.32-1) …
Processing triggers for libc6 …
ldconfig deferred processing now taking place
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
irb1.8 libopenssl-ruby1.8 libreadline-ruby1.8 libruby1.8 rdoc1.8 ri1.8 ruby1.8
Suggested packages:
graphviz ruby1.8-examples
The following NEW packages will be installed:
irb irb1.8 libopenssl-ruby libopenssl-ruby1.8 libreadline-ruby1.8 libruby1.8 libyaml-ruby libzlib-ruby
rdoc rdoc1.8 ri ri1.8 ruby ruby1.8 ruby1.8-dev
0 upgraded, 15 newly installed, 0 to remove and 26 not upgraded.
Need to get 4994kB of archives.
After unpacking 54.7MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com gutsy/main libruby1.8 1.8.6.36-1ubuntu3 [1566kB]
Get:2 http://archive.ubuntu.com gutsy/main ruby1.8 1.8.6.36-1ubuntu3 [239kB]
Get:3 http://archive.ubuntu.com gutsy/universe libreadline-ruby1.8 1.8.6.36-1ubuntu3 [218kB]
Get:4 http://archive.ubuntu.com gutsy/universe irb1.8 1.8.6.36-1ubuntu3 [258kB]
Get:5 http://archive.ubuntu.com gutsy/universe irb 1.8.2-1 [3660B]
Get:6 http://archive.ubuntu.com gutsy/universe libopenssl-ruby1.8 1.8.6.36-1ubuntu3 [316kB]
Get:7 http://archive.ubuntu.com gutsy/universe libopenssl-ruby 1.0.0+ruby1.8.2-1 [3568B]
Get:8 http://archive.ubuntu.com gutsy/universe libyaml-ruby 1.8.2-1 [3688B]
Get:9 http://archive.ubuntu.com gutsy/universe libzlib-ruby 0.6.0+ruby1.8.2-1 [3558B]
Get:10 http://archive.ubuntu.com gutsy/universe rdoc1.8 1.8.6.36-1ubuntu3 [331kB]
Get:11 http://archive.ubuntu.com gutsy/universe rdoc 1.8.2-1 [3852B]
Get:12 http://archive.ubuntu.com gutsy/universe ri1.8 1.8.6.36-1ubuntu3 [1285kB]
Get:13 http://archive.ubuntu.com gutsy/universe ri 1.8.2-1 [3762B]
Get:14 http://archive.ubuntu.com gutsy/main ruby 1.8.2-1 [19.0kB]
Get:15 http://archive.ubuntu.com gutsy/main ruby1.8-dev 1.8.6.36-1ubuntu3 [741kB]
Fetched 4994kB in 13s (364kB/s)
Selecting previously deselected package libruby1.8.
(Reading database … 29822 files and directories currently installed.)
Unpacking libruby1.8 (from …/libruby1.8_1.8.6.36-1ubuntu3_i386.deb) …
Selecting previously deselected package ruby1.8.
Unpacking ruby1.8 (from …/ruby1.8_1.8.6.36-1ubuntu3_i386.deb) …
Selecting previously deselected package libreadline-ruby1.8.
Unpacking libreadline-ruby1.8 (from …/libreadline-ruby1.8_1.8.6.36-1ubuntu3_i386.deb) …
Selecting previously deselected package irb1.8.
Unpacking irb1.8 (from …/irb1.8_1.8.6.36-1ubuntu3_all.deb) …
Selecting previously deselected package irb.
Unpacking irb (from …/archives/irb_1.8.2-1_all.deb) …
Selecting previously deselected package libopenssl-ruby1.8.
Unpacking libopenssl-ruby1.8 (from …/libopenssl-ruby1.8_1.8.6.36-1ubuntu3_i386.deb) …
Selecting previously deselected package libopenssl-ruby.
Unpacking libopenssl-ruby (from …/libopenssl-ruby_1.0.0+ruby1.8.2-1_all.deb) …
Selecting previously deselected package libyaml-ruby.
Unpacking libyaml-ruby (from …/libyaml-ruby_1.8.2-1_all.deb) …
Selecting previously deselected package libzlib-ruby.
Unpacking libzlib-ruby (from …/libzlib-ruby_0.6.0+ruby1.8.2-1_all.deb) …
Selecting previously deselected package rdoc1.8.
Unpacking rdoc1.8 (from …/rdoc1.8_1.8.6.36-1ubuntu3_all.deb) …
Selecting previously deselected package rdoc.
Unpacking rdoc (from …/archives/rdoc_1.8.2-1_all.deb) …
Selecting previously deselected package ri1.8.
Unpacking ri1.8 (from …/ri1.8_1.8.6.36-1ubuntu3_all.deb) …
Selecting previously deselected package ri.
Unpacking ri (from …/archives/ri_1.8.2-1_all.deb) …
Selecting previously deselected package ruby.
Unpacking ruby (from …/archives/ruby_1.8.2-1_all.deb) …
Selecting previously deselected package ruby1.8-dev.
Unpacking ruby1.8-dev (from …/ruby1.8-dev_1.8.6.36-1ubuntu3_i386.deb) …
Setting up libruby1.8 (1.8.6.36-1ubuntu3) …

Setting up ruby1.8 (1.8.6.36-1ubuntu3) …
Setting up libreadline-ruby1.8 (1.8.6.36-1ubuntu3) …
Setting up irb1.8 (1.8.6.36-1ubuntu3) …

Setting up irb (1.8.2-1) …
Setting up libopenssl-ruby1.8 (1.8.6.36-1ubuntu3) …
Setting up libopenssl-ruby (1.0.0+ruby1.8.2-1) …
Setting up libyaml-ruby (1.8.2-1) …
Setting up libzlib-ruby (0.6.0+ruby1.8.2-1) …
Setting up rdoc1.8 (1.8.6.36-1ubuntu3) …
Setting up rdoc (1.8.2-1) …
Setting up ri1.8 (1.8.6.36-1ubuntu3) …
Setting up ri (1.8.2-1) …
Setting up ruby (1.8.2-1) …
Setting up ruby1.8-dev (1.8.6.36-1ubuntu3) …
Processing triggers for libc6 …
ldconfig deferred processing now taking place
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
libgems-ruby1.8
The following NEW packages will be installed:
libgems-ruby1.8 rubygems
0 upgraded, 2 newly installed, 0 to remove and 26 not upgraded.
Need to get 468kB of archives.
After unpacking 7918kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com gutsy/universe libgems-ruby1.8 0.9.4-1ubuntu1 [416kB]
Get:2 http://archive.ubuntu.com gutsy/universe rubygems 0.9.4-1ubuntu1 [51.5kB]
Fetched 468kB in 2s (173kB/s)
Selecting previously deselected package libgems-ruby1.8.
(Reading database … 41175 files and directories currently installed.)
Unpacking libgems-ruby1.8 (from …/libgems-ruby1.8_0.9.4-1ubuntu1_all.deb) …
Selecting previously deselected package rubygems.
Unpacking rubygems (from …/rubygems_0.9.4-1ubuntu1_all.deb) …
Setting up libgems-ruby1.8 (0.9.4-1ubuntu1) …
Setting up rubygems (0.9.4-1ubuntu1) …
Updating RubyGems…
Bulk updating Gem source index for: http://gems.rubyforge.org
Attempting remote update of rubygems-update
ERROR: While executing gem … (Gem::GemNotFoundException)
Could not find rubygems-update (> 0) in any repository
Bulk updating Gem source index for: http://gems.rubyforge.org
Successfully installed rails-2.0.2
Successfully installed rake-0.8.1
Successfully installed activesupport-2.0.2
Successfully installed activerecord-2.0.2
Successfully installed actionpack-2.0.2
Successfully installed actionmailer-2.0.2
Successfully installed activeresource-2.0.2
Installing ri documentation for rake-0.8.1…
Installing ri documentation for activesupport-2.0.2…
Installing ri documentation for activerecord-2.0.2…
Installing ri documentation for actionpack-2.0.2…
Installing ri documentation for actionmailer-2.0.2…
Installing ri documentation for activeresource-2.0.2…
Installing RDoc documentation for rake-0.8.1…
Installing RDoc documentation for activesupport-2.0.2…
Installing RDoc documentation for activerecord-2.0.2…
Installing RDoc documentation for actionpack-2.0.2…
Installing RDoc documentation for actionmailer-2.0.2…
Installing RDoc documentation for activeresource-2.0.2…
Successfully installed rails-2.0.2
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
dpkg-dev g++ g++-4.1 libstdc++6-4.1-dev patch
Suggested packages:
debian-keyring g++-multilib g++-4.1-multilib gcc-4.1-doc libstdc++6-4.1-doc diff-doc
The following NEW packages will be installed:
build-essential dpkg-dev g++ g++-4.1 libstdc++6-4.1-dev patch
0 upgraded, 6 newly installed, 0 to remove and 26 not upgraded.
Need to get 3995kB of archives.
After unpacking 14.6MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com gutsy/main libstdc++6-4.1-dev 4.1.2-16ubuntu2 [1129kB]
Get:2 http://archive.ubuntu.com gutsy/main g++-4.1 4.1.2-16ubuntu2 [2600kB]
Get:3 http://archive.ubuntu.com gutsy/main g++ 4:4.1.2-9ubuntu2 [1440B]
Get:4 http://archive.ubuntu.com gutsy/main patch 2.5.9-4 [95.6kB]
Get:5 http://archive.ubuntu.com gutsy/main dpkg-dev 1.14.5ubuntu16 [162kB]
Get:6 http://archive.ubuntu.com gutsy/main build-essential 11.3ubuntu1 [7066B]
Fetched 3995kB in 12s (332kB/s)
Selecting previously deselected package libstdc++6-4.1-dev.
(Reading database … 42839 files and directories currently installed.)
Unpacking libstdc++6-4.1-dev (from …/libstdc++6-4.1-dev_4.1.2-16ubuntu2_i386.deb) …
Selecting previously deselected package g++-4.1.
Unpacking g++-4.1 (from …/g++-4.1_4.1.2-16ubuntu2_i386.deb) …
Selecting previously deselected package g++.
Unpacking g++ (from …/g++_4%3a4.1.2-9ubuntu2_i386.deb) …
Selecting previously deselected package patch.
Unpacking patch (from …/patch_2.5.9-4_i386.deb) …
Selecting previously deselected package dpkg-dev.
Unpacking dpkg-dev (from …/dpkg-dev_1.14.5ubuntu16_all.deb) …
Selecting previously deselected package build-essential.
Unpacking build-essential (from …/build-essential_11.3ubuntu1_i386.deb) …
Setting up patch (2.5.9-4) …
Setting up dpkg-dev (1.14.5ubuntu16) …
Setting up libstdc++6-4.1-dev (4.1.2-16ubuntu2) …
Setting up g++-4.1 (4.1.2-16ubuntu2) …
Setting up g++ (4:4.1.2-9ubuntu2) …

Setting up build-essential (11.3ubuntu1) …
Select which gem to install for your platform (i486-linux)
1. mongrel 1.1.4 (x86-mswin32-60)
2. mongrel 1.1.4 (java)
3. mongrel 1.1.4 (ruby)
4. mongrel 1.1.3 (ruby)
5. mongrel 1.1.3 (i386-mswin32)
6. mongrel 1.1.3 (java)
7. Skip this gem
8. Cancel installation
> 3
Install required dependency gem_plugin? [Yn] y
Install required dependency daemons? [Yn]
Install required dependency fastthread? [Yn]
Select which gem to install for your platform (i486-linux)
1. fastthread 1.0.1 (mswin32)
2. fastthread 1.0.1 (ruby)
3. Skip this gem
4. Cancel installation
> 2
Building native extensions. This could take a while…
Install required dependency cgi_multipart_eof_fix? [Yn]
Building native extensions. This could take a while…
Successfully installed mongrel-1.1.4
Successfully installed gem_plugin-0.2.3
Successfully installed daemons-1.0.9
Successfully installed fastthread-1.0.1
Successfully installed cgi_multipart_eof_fix-2.5.0
Installing ri documentation for mongrel-1.1.4…
Installing ri documentation for gem_plugin-0.2.3…
Installing ri documentation for daemons-1.0.9…
Installing ri documentation for fastthread-1.0.1…

No definition for dummy_dump

No definition for dummy_dump

No definition for rb_queue_marshal_load

No definition for rb_queue_marshal_dump
Installing ri documentation for cgi_multipart_eof_fix-2.5.0…
Installing RDoc documentation for mongrel-1.1.4…
Installing RDoc documentation for gem_plugin-0.2.3…
Installing RDoc documentation for daemons-1.0.9…
Installing RDoc documentation for fastthread-1.0.1…

No definition for dummy_dump

No definition for dummy_dump

No definition for rb_queue_marshal_load

No definition for rb_queue_marshal_dump
Installing RDoc documentation for cgi_multipart_eof_fix-2.5.0…
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
libdbd-mysql-perl libdbi-perl libmysql-ruby1.8 libmysqlclient15off libnet-daemon-perl libplrpc-perl
mysql-client-5.0 mysql-common mysql-server-5.0
Suggested packages:
dbishell libcompress-zlib-perl mysql-doc-5.0 tinyca
Recommended packages:
mailx
The following NEW packages will be installed:
libdbd-mysql-perl libdbi-perl libmysql-ruby libmysql-ruby1.8 libmysqlclient15off libnet-daemon-perl
libplrpc-perl mysql-client-5.0 mysql-common mysql-server mysql-server-5.0
0 upgraded, 11 newly installed, 0 to remove and 26 not upgraded.
Need to get 37.3MB of archives.
After unpacking 110MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com gutsy-updates/main mysql-common 5.0.45-1ubuntu3.1 [56.1kB]
Get:2 http://archive.ubuntu.com gutsy/main libnet-daemon-perl 0.38-1.1 [45.9kB]
Get:3 http://archive.ubuntu.com gutsy/main libplrpc-perl 0.2017-1.1 [35.0kB]
Get:4 http://archive.ubuntu.com gutsy/main libdbi-perl 1.57-1 [791kB]
Get:5 http://archive.ubuntu.com gutsy-updates/main libmysqlclient15off 5.0.45-1ubuntu3.1 [1867kB]
Get:6 http://archive.ubuntu.com gutsy/main libdbd-mysql-perl 4.004-2 [136kB]
Get:7 http://archive.ubuntu.com gutsy-updates/main mysql-client-5.0 5.0.45-1ubuntu3.1 [7493kB]
Get:8 http://archive.ubuntu.com gutsy-updates/main mysql-server-5.0 5.0.45-1ubuntu3.1 [26.8MB]
Get:9 http://archive.ubuntu.com gutsy/universe libmysql-ruby1.8 2.7.3-1 [51.1kB]
Get:10 http://archive.ubuntu.com gutsy/universe libmysql-ruby 2.7.3-1 [5058B]
Get:11 http://archive.ubuntu.com gutsy-updates/main mysql-server 5.0.45-1ubuntu3.1 [50.1kB]
Fetched 37.3MB in 35s (1038kB/s)
Preconfiguring packages …
Selecting previously deselected package mysql-common.
(Reading database … 43462 files and directories currently installed.)
Unpacking mysql-common (from …/mysql-common_5.0.45-1ubuntu3.1_all.deb) …
Selecting previously deselected package libnet-daemon-perl.
Unpacking libnet-daemon-perl (from …/libnet-daemon-perl_0.38-1.1_all.deb) …
Selecting previously deselected package libplrpc-perl.
Unpacking libplrpc-perl (from …/libplrpc-perl_0.2017-1.1_all.deb) …
Selecting previously deselected package libdbi-perl.
Unpacking libdbi-perl (from …/libdbi-perl_1.57-1_i386.deb) …
Selecting previously deselected package libmysqlclient15off.
Unpacking libmysqlclient15off (from …/libmysqlclient15off_5.0.45-1ubuntu3.1_i386.deb) …
Selecting previously deselected package libdbd-mysql-perl.
Unpacking libdbd-mysql-perl (from …/libdbd-mysql-perl_4.004-2_i386.deb) …
Selecting previously deselected package mysql-client-5.0.
Unpacking mysql-client-5.0 (from …/mysql-client-5.0_5.0.45-1ubuntu3.1_i386.deb) …
Setting up mysql-common (5.0.45-1ubuntu3.1) …
Selecting previously deselected package mysql-server-5.0.
(Reading database … 43702 files and directories currently installed.)
Unpacking mysql-server-5.0 (from …/mysql-server-5.0_5.0.45-1ubuntu3.1_i386.deb) …
Selecting previously deselected package libmysql-ruby1.8.
Unpacking libmysql-ruby1.8 (from …/libmysql-ruby1.8_2.7.3-1_i386.deb) …
Selecting previously deselected package libmysql-ruby.
Unpacking libmysql-ruby (from …/libmysql-ruby_2.7.3-1_all.deb) …
Selecting previously deselected package mysql-server.
Unpacking mysql-server (from …/mysql-server_5.0.45-1ubuntu3.1_all.deb) …
Setting up libnet-daemon-perl (0.38-1.1) …
Setting up libplrpc-perl (0.2017-1.1) …
Setting up libdbi-perl (1.57-1) …
Setting up libmysqlclient15off (5.0.45-1ubuntu3.1) …

Setting up libdbd-mysql-perl (4.004-2) …
Setting up mysql-client-5.0 (5.0.45-1ubuntu3.1) …

Setting up mysql-server-5.0 (5.0.45-1ubuntu3.1) …
* Stopping MySQL database server mysqld [ OK ]
* Starting MySQL database server mysqld [ OK ]
* Checking for corrupt, not cleanly closed and upgrade needing tables.

Setting up libmysql-ruby1.8 (2.7.3-1) …
Setting up libmysql-ruby (2.7.3-1) …
Setting up mysql-server (5.0.45-1ubuntu3.1) …
Processing triggers for libc6 …
ldconfig deferred processing now taking place
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libmysqlclient-dev is a virtual package provided by:
libmysqlclient15-dev 5.0.45-1ubuntu3.1
You should explicitly select one to install.
E: Package libmysqlclient-dev has no installation candidate
Select which gem to install for your platform (i486-linux)
1. mysql 2.7.3 (mswin32)
2. mysql 2.7.1 (mswin32)
3. mysql 2.7 (ruby)
4. mysql 2.6 (ruby)
5. Skip this gem
6. Cancel installation
> 3
Building native extensions. This could take a while…
ERROR: While executing gem … (Gem::Installer::ExtensionBuildError)
ERROR: Failed to build gem native extension.

ruby extconf.rb install mysql
checking for mysql_query() in -lmysqlclient… no
checking for main() in -lm… yes
checking for mysql_query() in -lmysqlclient… no
checking for main() in -lz… yes
checking for mysql_query() in -lmysqlclient… no
checking for main() in -lsocket… no
checking for mysql_query() in -lmysqlclient… no
checking for main() in -lnsl… yes
checking for mysql_query() in -lmysqlclient… no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/bin/ruby1.8
–with-mysql-config
–without-mysql-config
–with-mysql-dir
–without-mysql-dir
–with-mysql-include
–without-mysql-include=${mysql-dir}/include
–with-mysql-lib
–without-mysql-lib=${mysql-dir}/lib
–with-mysqlclientlib
–without-mysqlclientlib
–with-mlib
–without-mlib
–with-mysqlclientlib
–without-mysqlclientlib
–with-zlib
–without-zlib
–with-mysqlclientlib
–without-mysqlclientlib
–with-socketlib
–without-socketlib
–with-mysqlclientlib
–without-mysqlclientlib
–with-nsllib
–without-nsllib
–with-mysqlclientlib
–without-mysqlclientlib

Gem files will remain installed in /var/lib/gems/1.8/gems/mysql-2.7 for inspection.
Results logged to /var/lib/gems/1.8/gems/mysql-2.7/gem_make.out
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
libjasper1 liblcms1 libmagick9
Suggested packages:
gs html2ps lpr libjasper-runtime liblcms-utils libwmf-bin
The following NEW packages will be installed:
imagemagick libjasper1 liblcms1 libmagick9
0 upgraded, 4 newly installed, 0 to remove and 26 not upgraded.
Need to get 2280kB of archives.
After unpacking 8098kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com gutsy/main libjasper1 1.900.1-3 [142kB]
Get:2 http://archive.ubuntu.com gutsy/main liblcms1 1.16-5ubuntu3 [98.0kB]
Get:3 http://archive.ubuntu.com gutsy/main libmagick9 7:6.2.4.5.dfsg1-2ubuntu1 [1300kB]
Get:4 http://archive.ubuntu.com gutsy/main imagemagick 7:6.2.4.5.dfsg1-2ubuntu1 [740kB]
Fetched 2280kB in 11s (197kB/s)
Selecting previously deselected package libjasper1.
(Reading database … 45636 files and directories currently installed.)
Unpacking libjasper1 (from …/libjasper1_1.900.1-3_i386.deb) …
Selecting previously deselected package liblcms1.
Unpacking liblcms1 (from …/liblcms1_1.16-5ubuntu3_i386.deb) …
Selecting previously deselected package libmagick9.
Unpacking libmagick9 (from …/libmagick9_7%3a6.2.4.5.dfsg1-2ubuntu1_i386.deb) …
Selecting previously deselected package imagemagick.
Unpacking imagemagick (from …/imagemagick_7%3a6.2.4.5.dfsg1-2ubuntu1_i386.deb) …
Setting up libjasper1 (1.900.1-3) …

Setting up liblcms1 (1.16-5ubuntu3) …

Setting up libmagick9 (7:6.2.4.5.dfsg1-2ubuntu1) …

Setting up imagemagick (7:6.2.4.5.dfsg1-2ubuntu1) …

Processing triggers for libc6 …
ldconfig deferred processing now taking place
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libmagick-dev is a virtual package provided by:
graphicsmagick-libmagick-dev-compat 1.1.8-1
libmagick9-dev 7:6.2.4.5.dfsg1-2ubuntu1
You should explicitly select one to install.
E: Package libmagick-dev has no installation candidate
Building native extensions. This could take a while…
ERROR: While executing gem … (Gem::Installer::ExtensionBuildError)
ERROR: Failed to build gem native extension.

ruby extconf.rb install rmagick
checking for Ruby version >= 1.8.2… yes
checking for Magick-config… no
Can’t install RMagick 2.2.2. Can’t find Magick-config in /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/bin/ruby1.8

Gem files will remain installed in /var/lib/gems/1.8/gems/rmagick-2.2.2 for inspection.
Results logged to /var/lib/gems/1.8/gems/rmagick-2.2.2/ext/RMagick/gem_make.out
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Couldn’t find package capistrano
root@ubuntu:/home/ubuntu# hi there
The program ‘hi’ is currently not installed. You can install it by typing:
apt-get install hmake

[1]+ Stopped hi there
root@ubuntu:/home/ubuntu# tail rails2install.sh
#touch openssl.DONE

apt-get -y install imagemagick
apt-get -y install libmagick-dev
gem install rmagick
touch imagemagick.rmagick.DONE

apt-get -y install puppet capistrano
touch puppet.DONEroot@ubuntu:/home/ubuntu# apt-get install puppet
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
facter libshadow-ruby1.8 libxmlrpc-ruby
The following NEW packages will be installed:
facter libshadow-ruby1.8 libxmlrpc-ruby puppet
0 upgraded, 4 newly installed, 0 to remove and 26 not upgraded.
Need to get 382kB of archives.
After unpacking 2662kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://archive.ubuntu.com gutsy/universe facter 1.3.7-1 [14.0kB]
Get:2 http://archive.ubuntu.com gutsy/universe libshadow-ruby1.8 1.4.1-7 [8388B]
Get:3 http://archive.ubuntu.com gutsy/universe libxmlrpc-ruby 1.8.2-1 [3612B]
Get:4 http://archive.ubuntu.com gutsy/universe puppet 0.22.4-2 [356kB]
Fetched 382kB in 6s (62.4kB/s)
Selecting previously deselected package facter.
(Reading database … 45854 files and directories currently installed.)
Unpacking facter (from …/facter_1.3.7-1_all.deb) …
Selecting previously deselected package libshadow-ruby1.8.
Unpacking libshadow-ruby1.8 (from …/libshadow-ruby1.8_1.4.1-7_i386.deb) …
Selecting previously deselected package libxmlrpc-ruby.
Unpacking libxmlrpc-ruby (from …/libxmlrpc-ruby_1.8.2-1_all.deb) …
Selecting previously deselected package puppet.
Unpacking puppet (from …/puppet_0.22.4-2_all.deb) …
Setting up facter (1.3.7-1) …
Setting up libshadow-ruby1.8 (1.4.1-7) …
Setting up libxmlrpc-ruby (1.8.2-1) …
Setting up puppet (0.22.4-2) …
* Starting puppet configuration management tool [ OK ]

root@ubuntu:/home/ubuntu# apt-get install capistrano
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Couldn’t find package capistrano
root@ubuntu:/home/ubuntu# apt-cache search capistrano
root@ubuntu:/home/ubuntu# vi rails2install.sh
root@ubuntu:/home/ubuntu#

root@ubuntu:/home/ubuntu# gem install mysql
Need to update 29 gems from http://gems.rubyforge.org
………………………..
complete
Select which gem to install for your platform (i486-linux)
1. mysql 2.7.3 (mswin32)
2. mysql 2.7.1 (mswin32)
3. mysql 2.7 (ruby)
4. mysql 2.6 (ruby)
5. Skip this gem
6. Cancel installation
> 3
Building native extensions. This could take a while…
Successfully installed mysql-2.7
root@ubuntu:/home/ubuntu#

Leave a Reply